Lors de la compilation de enlightenment, j’ai eu l’erreur suivante :

configure: Start EPhysics checks
configure: error: pkg-config missing bullet >= 2.80

Bullet est une librairie physique.

Bullet n’étant pas disponible sous Debian, je l’ai compilé. Pour l’installer, il faut le télécharger ici : bullet-2.81_2.81+rev2613-1_amd64.deb.tar.gz

tar xvzf bullet-2.81_2.81+rev2613-1_amd64.deb.tar.gz
dpkg -i bullet-2.81_2.81+rev2613-1_amd64.deb

Pour l’installer à la main :

apt-get install cmake freeglut3-dev
wget https://bullet.googlecode.com/files/bullet-2.81-rev2613.tgz
tar xvzf bullet-2.81-rev2613.tgz
cd bullet-2.81-rev2613
cmake -D BUILD_SHARED_LIBS=true .
make
make install

On vérifie que c’est bien installé :

ldconfig -v | grep -i bullet
ldconfig: Path `/usr/lib/x86_64-linux-gnu' given more than once
    libBulletDynamics.so.2.81 -> libBulletDynamics.so.2.81
    libBulletCollision.so.2.81 -> libBulletCollision.so.2.81
    libBulletSoftBody.so.2.81 -> libBulletSoftBody.so.2.81

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *