Voici des paquets Bacula 5 qui fonctionnent sous Debian 4.0. Avec les versions précédentes (< 5.0), certaines fonctionnalités de bacula ne sont pas disponibles. Si vous avez besoin d'utiliser bacula-fd 5 sur des vieilles version de debian, voici comment faire :

  • Sous Lenny, il suffit de les installer via les backports :
  • Ajouter au fichier /etc/apt/sources.list les lignes suivantes :

    deb http://ftp.debian.org/debian-backports lenny-backports main
    deb-src http://ftp.debian.org/debian-backports lenny-backports main
    apt-get update
    apt-get install -t lenny-backports bacula-fd

    Sous Etch, il faut utiliser les paquets suivants : bacula_5.0.2-etch.tar.gz

    tar xvzf bacula_5.0.2-etch.tar.gz

    Sur une machine AMD64 :

    dpkg -i bacula/*amd64.deb

    Sur une machine i386 :

    dpkg -i bacula/*i386.deb

    Il y a aussi la libpyton2.6 au besoin, si vous rencontrez des problèmes avec le .deb. Elle s’utilisent comme ceci :

    cp bacula/libpython2.6.so.1.0_amd64 /usr/lib/libpython2.6.so.1.0

    ou

    cp bacula/libpython2.6.so.1.0_i386 /usr/lib/libpython2.6.so.1.0
    ln -s /usr/lib/libpython2.6.so.1.0 /usr/lib/libpython2.6.so.1

    Puis il ne reste plus qu’à tester :

    /etc/init.d/bacula-fd start

    This article has 2 comments

    1. Pedro

      Hi,
      Do you happen to have a solution for etch with bacula-fd 5.2 ? I’m in desperate need of backing up a i386 etch machine and I need LZO compression, something that is only available in version 5.2 of the bacula client.

      1. VaLouille

        Hello,

        Unfortunately I don’t have 5.2 debs. The solution for you would be to install the debs I provided and then try the re-build bacula-fd 5.2 on a Sarge virtual machine.

        Good luck 🙂

    Laisser un commentaire

    Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *